Как определить наиболее подходящую версию прошивки?


#1

Доброго дня!

На форуме неоднократно встречал замечания по поводу правильного подбора прошивки под конкретную ревизию платы. Хотел уточнить по поводу своей. Какая наиболее стабильная прошивка? Дело в том, что ни одна из прошивок 58 не ставится. Выдает, что версия несовместима. Прошивки 55 ставятся, но становится невозможным установить Inspector SCADA.

S/N ABY2EJ22
на обратной стороне платы 5 r. 8.1


#2

#3

Добрый день, advisores!
Хотел уточнить: вы через Web-интерфейс обновляетесь, или заливаете прошивку на устройство через USBtoSerial? У вас изначально стояла версия 20170330…, последняя стабильная. Она сейчас стоит на контроллере, или у вас прошивка какой-то версии от 55?


#4

Добрый день, Kilpio!

Какая версия стояла изначально затрудняюсь ответить, к сожалению. Сейчас стоит версия от 55.
Устройство досталось мне от другого хозяина. Я обратил внимание, что в конфигурациях нет SCADA Client и WebUI Configuration schema. Пытался обновить прошивку через Web-интерфейс, но от 58 ни одна не ставилась (выводилась ошибка, что она не совместима). Версии от 55 ставятся, но проблему это не решает. Inspector SCADA клиент не ставится по инструкции, выдавая ошибку. Варианты с update, upgrade аналогично не помогают. Пока победить указанные проблемы не получается.


#5

Скажите, а вот по этой инструкции вы не пробовали прошивать контроллер: Wiren Board 5: Восстановление прошивки
Но только при этом теряются все пользовательские данные.


#6

Добрый день, Kilpio.

Да, пробовал. Таким способом прошивка проходит (поставил 20170330). Единственно срабатывает аппаратный watchdog. Пришлось принудительно выключать. Однако, прошивка не решает проблему с возможностью установки wb-scada-client. SCADA Client и WebUI Configuration schema по прежнему отсутствуют. При установке wb-scada-client выводится сообщение:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
b-scada-client : Depends: python-mqttrpc but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Установка python-mqttrpc вызывает ошибку:

The following packages have unmet dependencies:
python-mqttrpc : Depends: python:any (< 2.8) but it is not installable
Depends: python:any (>= 2.7.5-5~) but it is not installable

Буду весьма признателен, если поможете разобраться. Варианты с предварительным update, upgrade не помогли.


#7

#8

Яндекс.Метрика