Ошибка работы датчиков 1-wire


#21

а в /var/log/messages какие-нибудь ошибки про w1 есть?


#22

Вот, например:

Mar 30 09:08:56 wirenboard-ARAXKJYF user.info kernel: [1108616.194227] w1_master_driver w1_bus_master1: Family 82 for 82.8e840822c0c6.37 is not registered.


#23

Евгений, Вы ответьте хоть что-то. Мне перегружать уже контроллер, чтобы все заработало или будете ещё что-то рекомендовать выполнить? Пробовал вытащить провод из разъема контроллера 1-wire, но ничего не изменилось. Я допускаю, что проблема программная в контроллере. Жду скорейших указаний!


#24
  1. Эта ошибка в логе была один раз или повторяется постоянно?

  2. Посмотрите пожалуйста в разделе Devices в веб-интерфейсе в блоке Discrete I/O кнопку 5Vout. Она включена?


#25

У нас, на одном объекте, тоже периодически подвисали 1W датчики. Решили проблему добавлением правила, которое периодически на пару секунд переключает питание датчиков на 3V и обратно. Уже почти год работает без зависаний. Метод может и кривоват, но позволил решить проблему не выезжая на объект.


#26

Повторяется

Включена всегда


#27

Понятно. Попробуйте перезагрузить контроллер и больше ничего не делать и не трогать.
Если поможет - это будет очень странно, будем разбираться.


#28

Помогло. Работает теперь


#29

Ок, напишите как снова проблема появится - будем дальше диагностировать.


#30

Проблема опять дала о себе знать.

  1. Откуда появились несуществующие адреса датчиков? Их несколько десятков точно.

  2. Почему не могу увидеть в истории показания предыдущего дня?

Есть связь с ошибкой работы mqtt-serial из другого моего поста сегодня?


Яндекс.Метрика