Ошибка установки wb-mqtt-mbgate


#1

Приветствую!
Контроллер WB5 firmware version 201807181620
Пытаюсь поставить wb-mqtt-mbgate:

root@wirenboard-AITWMGFU:/# apt-get update && apt-get install wb-mqtt-mbgate
Ign:1 http://mirror.yandex.ru/debian stretch InRelease
Hit:2 http://mirror.yandex.ru/debian stretch-updates InRelease
Hit:3 http://security.debian.org stretch/updates InRelease
Hit:4 http://releases.contactless.ru/stable/stretch stretch InRelease
Hit:6 http://mirror.yandex.ru/debian stretch Release
Hit:5 http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease
Reading package lists... Done
W: No sandbox user '_apt' on the system, can not drop privileges
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
wb-mqtt-mbgate : Depends: liblog4cpp5 (>= 1.0) but it is not installable
E: Unable to correct problems, you have held broken packages.
root@wirenboard-AITWMGFU:/#

Если попробовать поставить недостающий пакет, то

root@wirenboard-AITWMGFU:/# apt-get install liblog4cpp5
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package liblog4cpp5 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  liblog4cpp5v5

E: Package 'liblog4cpp5' has no installation candidate
root@wirenboard-AITWMGFU:/#

Ну а liblog4cpp5 установлен

 root@wirenboard-AITWMGFU:/# dpkg -l | grep liblog4cpp5
 ii  liblog4cpp5-dev                 1.1.1-3                        armel        C++ library for flexible logging (development)
ii  liblog4cpp5v5                   1.1.1-3                        armel        C++ library for flexible logging (runtime)
 root@wirenboard-AITWMGFU:/#

Подскажите пожалуйста как быть


#2

#3

починил, сделайте apt-get update и попробуйте снова


#4

Да.Теперь ошибки нет. Установил. Спасибо!


Яндекс.Метрика