Перестало показывать входное напряжение


#1

Добрый день!
Перестало отбаражаться входное напряжение

root@wirenboard:~# mosquitto_sub -C 1 -t /devices/wb-adc/controls/Vin
nan
Но показывает напряжение аккумулятора (хотя его нет)

root@wirenboard:~# mosquitto_sub -C 1 -t /devices/wb-adc/controls/BAT
3.977
С чем может быть связано. Блок питание покупал в комплекте faraday на DIN рейку


#2

выложите пожалуйста содержимое файла /etc/wb-homa-adc.conf


#3
// Configuration options
{
"device_name" : "Analog Inputs",
"debug" : false,
"iio_channels" : [
     {
            "id" : "A1",
            "averaging_window": 1,
            "channel_number" : 1,
            "multiplier" : 3.800,
            "decimal_places" : 2
    },
    {
            "id" : "A2",
            "averaging_window": 1,
            "channel_number" : 2,
            "multiplier" : 3.800,
            "decimal_places" : 2
    },
    {
            "id" : "A3",
            "averaging_window": 1,
            "channel_number" : 3,
            "multiplier" : 3.800,
            "decimal_places" : 2
    },
    {
            "id" : "A4",
            "averaging_window": 1,
            "channel_number" : 4,
            "multiplier" : 3.800,
            "decimal_places" : 2
    },
    {
            "id" : "R1",
            "channel_number" : 6,
            "type" : "ohm_meter",
            "averaging_window": 1,
            "decimal_places" : 0,
            "resistance1" : "1000kOhm",
            "resistance2" : "3150Ohm",
            "current" : 80,
            "multiplier" : 0.4518,
            "current_calibration_factor" : 1.06
    },
    {
            "id" : "Vin",
            "averaging_window": 1,
            "channel_number" : 5,
            "multiplier" : 3.80,
            "decimal_places" : 2
    },
    {
            "id" : "BAT",
            "averaging_window": 1,
            "channel_number" : 7,
            "multiplier" : 0.45175,
            "decimal_places" : 3,
            "max_voltage" : 7,
            "scale" : 1.80664062
    },
    {
            "id" : "5Vout",
            "averaging_window": 1,
            "channel_number" : 0,
            "multiplier" : 1.694,
            "decimal_places" : 2,
            "scale" : 0.4
    }
]
}

Сейчас подкрутил напряжение на блоке питания - стало показывать.

root@wirenboard:~# mosquitto_sub -C 1 -t /devices/wb-adc/controls/Vin
21.68


#4

по-моему это известный баг, попробуйте обновить пакет wb-homa-adc


Яндекс.Метрика